Skip to Content

0.9.4 make fails on Fedora 8

No replies
sstepoway
Offline
Joined: 04/17/2010

I've been running 0.9.3 ([u]fabulous[/u] software), which was installed from rpm's. But I now need to work on some tracks that will have to play on a Windows machine which is running 0.9.4. I know that I can take projects from 0.9.3 to 0.9.4, but I'd rather have the same on both systems. And the repos for Fedora8 and PlanetCCRMA (which I'm really running) don't seem to have 0.9.4.

So I sat down to build from the tar-ball (which I've done many times for other s/w), and after finding that a number of -devel packages were missing (installed via yum), I've hit this:

make[2]: Entering directory `/usr/local/hydrogen-0.9.4/extra/hydrogenPlayer'
g++ -o hydrogenPlayer HydrogenPlayer.o ../../libs/libhydrogen.a -lsndfile -ltar -llrdf -lasound -ljack -lFLAC -lFLAC++ -lQtXml -lQtGui -lQtCore -lpthread
/usr/lib/libcurl.so.4: undefined reference to `PK11_CreateGenericObject@NSS_3.12'
/usr/lib/libcurl.so.4: undefined reference to `SSL_ForceHandshakeWithTimeout@NSS_3.11.4'
collect2: ld returned 1 exit status
make[2]: *** [hydrogenPlayer] Error 1
make[2]: Leaving directory `/usr/local/hydrogen-0.9.4/extra/hydrogenPlayer'
make[1]: *** [sub-hydrogenPlayer-make_default] Error 2
make[1]: Leaving directory `/usr/local/hydrogen-0.9.4/extra'
make: *** [sub-extra-make_default] Error 2

I can't find anything that tells me what I'm missing (I'm sure that's the problem, or I've got an outdated version of something; the system is PlanetCCRMA/F8 upgraded from PlanetCCRMA/Fedora6). Any ideas??

Steve