Skip to Content

Clipping

4 replies [Last post]
naurus
Offline
Joined: 04/17/2010

Ok, so hydrogen works great and really helps me since i'm a composer/guitarist/song writer without a band, but it would help me more if it didn't always clip. All the effects I have clip every time they're played. That's even if its just a single Hi-Hat tap. It doesn't appear to be clipping on the equalizer, but I can definitely hear it. Especially on a kick drum. Any help would be great.

Jakob Lund
Offline
Joined: 04/17/2010

Which audio driver are you using? If you are using JACK, have you checked that there is only one connection from hydrogen into your soundcard? I've sometimes experienced clipping caused by a signal running doubly (e.g. from hydrogen into the sound card, AND from hydrogen into ardour, and then into the soundcard again)

naurus
Offline
Joined: 04/17/2010

I'm, so far, forced to use alsa. Ouch. I know. But if i use jack, i get this kind of problem in all my audio software.

Jakob Lund
Offline
Joined: 04/17/2010

To me it sounds like your problem might be fixable outside hydrogen (i.e. by changing the alsa configuration, switching audio drivers, or something else).

Does 'normal' software like media or music players behave nicely on your system?

naurus
Offline
Joined: 04/17/2010

When i use alsa, everything but hydrogen works great. When i use jack, everything gets clippy. But i realized that's because i'm not using the real time kernel. I'm working on upgrading to that right now.