Skip to Content

jack, xruns and hydrogen

3 replies [Last post]
yervah
Offline
Joined: 04/17/2010

hey guys, this issue started yesterday with no upgrades to my system.
hydrogen will not run with jack anymore.
I get a huge xrun and then I get the message that jack shutdown but jack is still running.

this is the message from qjackctl:

11:26:20.757 XRUN callback (1).
11:26:20.759 JACK connection graph change.
subgraph starting at qjackctl timed out (subgraph_wait_fd=21, status = 0, state = Running, pollret = 0 revents = 0x0)
bad status (1) for client Hydrogen-1 handling event (type = 8)
**** alsa_pcm: xrun of at least 0.836 msecs
11:26:20.891 JACK connection change.
11:26:35.074 ALSA connection graph change.
11:26:35.131 ALSA connection change.
11:26:36.300 JACK connection graph change.

hydrogen readout:

(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
cannot complete execution of the processing graph (Resource temporarily unavailable)
zombified - calling shutdown handler
QMetaObject::connectSlotsByName: No matching signal for on_upBTN_clicked()
QMetaObject::connectSlotsByName: No matching signal for on_downBTN_clicked()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(I) JackOutput getNumTracks get num tracks()
(W) int H2Core::audioEngine_process(uint32_t, void*)
(W) int H2Core::audioEngine_process(uint32_t, void*) ----XRUN----
(W) int H2Core::audioEngine_process(uint32_t, void*) XRUN of 7721.17 msec (7723.84 > 2.66667)
(W) int H2Core::audioEngine_process(uint32_t, void*) Ladspa process time = 0.003
(W) int H2Core::audioEngine_process(uint32_t, void*) ------------
(W) int H2Core::audioEngine_process(uint32_t, void*)
(I) OldDrumkitManager OldDrumkitManager INIT
(I) OldDrumkitManager updateDrumkitList [updateDrumkitList]

mrthraz
mrthraz's picture
Offline
Joined: 04/17/2010

make sure your inputs and outputs havnt changed in the jack setup

wolke
wolke's picture
Offline
Joined: 03/30/2010

this error is already fixed in svn changeset 258 and optimized in svn changeset 260.

checkout svn and recompile.

and... you can use scons to build and install.

scons
scons install

if you do not want to recompile hydrogen you have to disable track outputs in the preferences dialog.

greetings wolke

yervah
Offline
Joined: 04/17/2010

yep. thanx guys. it's been fixed for sometime now..