Skip to Content

raspberripi2 hyrogen trigger io live drum sound teste

9 replies [Last post]
EduSou
Offline
Joined: 02/14/2015

Hello, this is my first sound test, my project, Hyrogen, raspberrypi2, fame 505II hardwear, was recorded with my phone, but I think it's to realize the quality, gostva to hear criticism or suggestions.

I'm not professional drummer, the battery is my son, and it all started when the fame of the module began to malfunction.

raspberripi2 hyrogen trigger io live drum sound teste

Thanks

thijs
thijs's picture
Offline
Joined: 04/20/2010

seems that the video is private  :-(  you need to make it public for us to see

EduSou
Offline
Joined: 02/14/2015

yap sorry , they are public now , 

i solved my sound problem ( noise ) i use hdmi sound , but i have dane a step back , i alredy have a spi tft , on atent to put it to work all my job get on trach can , i am working on a new image a traing to have spi as a hdmi clone and then i will refine tune the hydrogen , i fond out if i use the atack option on instroment, ti ,50 or to 1,  i can get a mutch softer start of the beet sound , and it get more real, its not that hot on sound start , becase wen o beet the pad the sound was triggerd like i was duing it hard, and now i have more defenition on velocity i can fell the difrence betwin the instroment sound layers from the soft to hard beet.

EduSou
Offline
Joined: 02/14/2015

i think its public now

thijs
thijs's picture
Offline
Joined: 04/20/2010

hi EduSou

thanks for sharing !!

it sounds like there is quite a bit of latency. are you running jack on the PI?

 

grtz

thijs

EduSou
Offline
Joined: 02/14/2015

Hi thijs, yes i am running jack , i have a bit of problems with jack , if latency is dawn of 60 msec the sound get crazy distrorced , woth is the best conf for jack ? i have 1024 - 44100-3 same times work good with 512-44100-3, woht shod be the latenci for a good sound ?

i think i untherstend woht you mean the sound looks like it drags its no smoth and fast, is it? because in my understending the big difrence to the real module is this the sound fell slower and like it angs its not fluind , i hoope you untherstend my englich lol,  but one thing keeps mi going on the quality of the samples are realy bether thy are more real , last wekend i trayed a real drum and e think i get the felling and the power of the real live sound and the perl kit for hydrogen is the most look like. the acustic drum to.

i had to rebuil my sd card , becase of the spi tft, tests , but now i am on the goog way again, laredy can boot direct from spi and then wen i have to work in the software i can load x on hdmi , but i have to setup hydrogen again. because of my job i am having no time to play with the drum :( ,  

and becase i am a linux nob so everithing is a learnig processe, but i will get ther lol, and i am on a diy project to with my hi-hat pedal , my swith diy isnt that good but this is do a compatibility problem with the trigger io, 

back to jack , i am using the now jack witch came on raspberry image the last one, i think is jack1, on the 1º teste only on rasp no tested with trigger io connected, it sounds good and it´s stable no loss of sound, i will tray i hope this wekend everithing together and then try to change jack configuration to see if i can get the sound bether, less drag , do you know if i nead to path jack (patch -p1 -i ../jack1_stable_armel.diff)?

thanks for your patience

i get a strange thing wen i change the configuration on jack and restart it it dont shut down the service i have to reboot the pi, and it appen to with hidrogen , on prefrencies , if i change the setings is ask to restart the driver but jack dont restart sam times i get too jack instances on tasks i have to kill it and then restart hydrogen, but samtimes the sound gests crazy so back to last conf lol, 

 

 

EduSou
Offline
Joined: 02/14/2015

hi , i have testd alredy ( 5 min ago) the new config , and i conf jack to 128 - 48000 - 3 , it give mi 8ms on latency , and the sound works good , i didnt teste if it stops because its 10pm now , i will test tomorow , and i will do a new sound test video .i

i forget to see in debug woht is de output i know is jack but only after reboot i can see changes on jack, the service sems to dont realy stop , but now i can chamge the setings on jack to a low latency and jack retastarts , on last config wen i tray to chamge to lower latency it didnt start after changes made

 i am runing pi2 at 1Ghz i will undo the ouverclok te see if it isnt afect the performance 

now i hope i can say i have a stand alone Hydrogen raspberry drum :) 

thijs
thijs's picture
Offline
Joined: 04/20/2010

hi EduSou

looks like you are on the right track !

i think 8ms sounds very good for the PI and it should be enough to use with drums

 

"i get a strange thing wen i change the configuration on jack and restart it it dont shut down the service i have to reboot the pi"

could be jackdbus.  can you run this in a terminal : "ps ax | grep jack" and post the output here ?

 

grtz

Thijs

EduSou
Offline
Joined: 02/14/2015

Hi thijs, and thanks for reply , i think now its bether but the 8ms it wasnt realy runing i think , becase wen i get it runing i get the strange sound , and it only rum good if in debug window show 1024 48000

at moment i think the delay its on 16ms. 

i will try the command and post it tomorow thanks for helping

i did 2 mor videos today and iam realy trarting to like the sound ,

1 change made i add dwc_otg.speed=1 to the cmdline.txt

and it seems to rum bether, i trayed to rum usb sound card but i bet glich click sounds , i think is becase the scaling of the cpu.

but if i can get a good sound with internal sound by the hdmi it will be prefect, less things to deal with.

 video 1 sound test kit7 ( perl kit) 

video 2 kit6 ultra acustic

hi have a kit 5 with a remo kit ( Really Natural Remo.h2drumkit) but i am having trables with mute fuction on hi hat and shouking crash , the sound cuntinues in backgraund , i traing to solve this 

thay are public this time lol , didnt forget , pls give your opinion , for a drummer like mi its almost perfect lol 

i was reading bether abaut sound like the link http://wiki.linuxaudio.org/wiki/raspberrypi e never stop any services becase a cant get the script working but woht i think is less services runing mor memory and bether cpu performanc , so o will tray to do it . or you think it wil no be necessary ?

thanks 

 

 

EduSou
Offline
Joined: 02/14/2015

Sorry i forgot to run hydrogen 

pi@drum ~ $ ps ax | grep jack

 3244 ?        SLsl   0:02 /usr/bin/jackd -T -ndefault -dalsa -r192000 -p1024 -n3 -D -Chw:2 -Phw:2,1

 3260 pts/0    S+     0:00 grep --color=auto jack

this is my conf now 16ms