Skip to Content

Saved songs do not reload properly

8 replies [Last post]
shanneton
Offline
Joined: 04/17/2010

Hello,
First I'm really a great fan of Hydrogen that is my preferred music software on linux. BUT i have a big problem...
I build a drumkit from a set of sounds I recorded myself. I can design patterns and song with that drumkit and everything is ok. BUT when I save the project and reload it, patterns are modified and only use the two first instrument of the drumset are used : all the events previously distributed among the different instruments are "condensed" on the two first instruments.
Does anybody encountered the same behavior of the soft ?

mauser
Offline
Joined: 03/30/2010

Hi!

Which version of hydrogen are you using??

shanneton
Offline
Joined: 04/17/2010

The 9.4.0 (Feb 22 2010) version (the last one ?)

mauser
Offline
Joined: 03/30/2010

Hi!

I can't reproduce that here.. can you descibe it in more detail and maybe create a bug at https://www.assembla.com/spaces/hydrogen/tickets with that description?? That would be great!

shanneton
Offline
Joined: 04/17/2010

Hi,
Before to report the bug, would you try to reproduce it with my drumkit that is located here : http://dl.free.fr/ptHcJxW5A
The bug seems to allocate bad instrument id in the "note" section of the song file.
Thank you very much

wolke
wolke's picture
Offline
Joined: 03/30/2010

your drumkit xml file is broken.

the instrument id node is broken in your drumkit.xml file.

the instrument id node needs an integer value.
give each instrument an unique value. best is, to increment from one upwards.

shanneton
Offline
Joined: 04/17/2010

How do you edit the drumkit file ? Is it an archive like a zip ?

Thank you very much

mauser
Offline
Joined: 03/30/2010

Hi!!

Yes, a h2drumkit file is just a compressed(gzip) folder!
You can uncompress it and then edit the drumkit.xml file.
But please update your version of hydrogen to 0.9.4.1.
The 0.9.4.0 may produce those faulty drumkits if you're adding
your own instruments. It's a known bug and it was fixed in 0.9.4.1!

shanneton
Offline
Joined: 04/17/2010

Ok,
I fixed the problem by editing the xml drumkit file.
I'm sorry but I was sure to have the last version (0.4.9).
Thank you