Skip to Content

WinXP, Korg Nanopad, and Hydrogen not working. Please help.

4 replies [Last post]
jamato
Offline
Joined: 07/07/2011

I wanted to say that this looks like a great piece of software. I have exhausted my resources trying to get everything to communicate via MIDI. I have tried JACK and MIDIyoke. Neither allows the Nanopad to communicate with Hydrogen. I am running Hydrogen 0.9.6. Is this setup impossible?

I am far from a newbie with this stuff. I have been an audio engineer for 16 years. I have a few MIDI devices and have never had an issue. I was hoping to get this working and contribute some custom kits. Anybody have any suggestions?

wolke
wolke's picture
Offline
Joined: 03/30/2010

hydrogen handle audio and midi separate. hydrogen use every time portmidi as mididriver but can use portaudio or jack as audio-driver.

if your nanopad is correct installed into your system, normally it will listed under:

tools-> preferences -> midisystem -> input dropdown-menu. if everything is ok you find an entry like USB-Audiodevice or something similar.

I have no nanopad, but my cheap fame usb midi keyboard works like a charme.

 

one thing left. you must drive hydrogen via jack to get smallest audio latency. and here it is important that you start the  jack-server with an asio driver. so hydrogen can work connected to jack with asio typical small latencys. a howto to start jack with asio is available here: http://jackaudio.org/jack_on_windows . i personally like to make all my settings via jack-control a nice gui to admin the jackserver and his connections. http://hydrogen.popez.org/hcms/sites/default/files/pictures/hydrogenwind... will show a small set-up with asio4all|jack|hydrogen.

for example in a set-up with my rme multiface i can realise latencys ~2-4ms. as i know latencys under 10ms are not noticeable.

 

greetings wolke

 

p.s: one information left. i make a mistake as i create the hydrogen installer for windows. i include the libjack.dll. this produce a segfault if you have installed a jackversion which is different to the libjack.dll from hydrogen.

to solve this problem only delete libjack.dll in you hydrogen installation directory. typically under C:\Program Files\hydrogen . than everything works fine with each jack version.

 

jamato
Offline
Joined: 07/07/2011

Thank you for the reply Wolke! I am using jack with asio4all and that works perfectly. MIDI....not working. I tried a few different MIDI interfaces and I still have no MIDI light in Hydrogen. My MIDI devices are working perfectly with other software, though. My settings look correct in the preferences tab. Is there another place that I need to enable MIDI? It looks like Hydrogen sees the MIDI devices but is not recognizing a signal or something.

I already deleted libjack.dll previously when I was having problems with jack 1.9.7.

Best Regards,

Jason

 

Update: It looks like something in hydrogen is broken to me. I tested my midi inputs and outputs through REAPER and everything functioned perfectly. Hydrogen + MIDI=broken. I read all these posts about MIDI working in windows. I even tried all the workarounds to get it working with hydrogen. Hydrogen sees all my devices. I select one and restart driver. Then what? What am I missing? Thanks ahead to anyone interested in helping me with the problem. :)

tweed
Offline
Joined: 09/01/2012

I too am experiencing this:  yamaha keys > usb midi > midi yoke 1 (usb midi to midiyoke 1 connection properly made in midi ox) > H2.  No Midi light.  Works in Reaper.If i don't use midi yoke I do get midi signal into H2.  But I need to use midiyoke as I will be using ethernet midi applet which requires the use of midi yoke.  I also want to use win XP for H2 so I can output H2 drum audio to Antress Plugs which doesn't seem to work under vestige, wine, etc...

I know this is an old thread but any info would be much appreciated.

 

 

tweed
Offline
Joined: 09/01/2012

clarification:
yamaha keys > usb midi cable > midi yoke 1  > H2 does Not work. 

yamaha keys > usb midi cable > midi yoke 1  > Reaper Does Work.

yamaha keys > usb midi cable> H2 Does work (no midiyoke).

seems like H2 for windows doesn't like midiyoke??

using win XP.