Skip to Content

Synchronizing tempo between hydrogen and microkorg xl

4 replies [Last post]
el.atomo
Offline
Joined: 11/27/2011

Hi,

First of all I would like to thank the developers for such a great piece of software.

I'm trying to get hydrogen synchronized with my microkorg xl through MIDI. The initial setup is pretty straight forward, just the microkorg xl, jack and hydrogen (version 0.9.5).

Being a completely novice in this subject, my first intuitive attempt was setting the microkorg clock to external midi, connecting the hydrogen midi output to the korg input in the alsa tab of jack, and expecting magic to happen... and I realized it wouldn't be that easy. :)

After searching the forums I came accross the "jack transport mode" and the "jack time master mode" in hydrogen, which I blindly played with, and read also about the hydrogen midi-clock branch.

Right now I feel completely lost, and I would appreciate any hint about midi clock or alternative software setups.

Thanks a lot in advance.

wolke
wolke's picture
Offline
Joined: 03/30/2010

http://sourceforge.net/projects/jack-trans2midi/

this is your friend. a small tool to translate jack transport to midi clock. simple to use.

in hydrogen you only have to enable the jack transport slave button. not the master button.

also use qjackctl to make the connection from jack-trans2mid to your midi out port which is connected to the microkorg. there is no need to configure connections from hydrogen if you run under jack. the transport communication happens in the jack-driver. 

greetings wolke

el.atomo
Offline
Joined: 11/27/2011

Thanks a lot. I'm gonna try it right now.

el.atomo
Offline
Joined: 11/27/2011

I'm still having problems while synching.

The trans2midi app seems to do its job fine, I can see now an orange light blinking in my usb midi adapter while hydrogen is playing (although it doesn't blink "timed" with the bpm's in hydrogen), but I still can't make the microkorg work with it.

I set the microkorg midi clock to "ext midi" and tried almost every possible midi channel (by default is set to channel 1), but nothing happens.

Could it have something to do with midi clock format?

Greetings,

J

wolke
wolke's picture
Offline
Joined: 03/30/2010

against my previos post, try the jack transport master button. you need tempo information in jack transport. if you have only slave applications jack transport maybe have no infos about bpm's.

greetings wolke