Skip to Content

JackOSX "Error starting audio driver"

4 replies [Last post]
metalguitarist613
Offline
Joined: 08/12/2012

Hi, all.

I've been programming some drum tracks with quite a few tempo changes, which Hydrogen's export does not support, so I decided to use JackOSX to get the tracks in Ardour and export from there. However, I've run into a problem. Whenever I try to Jack enable H2 (in audio preferences), I get the error message "Error starting audio driver" and the output in H2 is muted. In addition, Hydrogen does not appear in the connections list on Jack. I've tried this with Jack open and with both Jack and Ardour open, but to no avail. My OS is 10.7.4. Any help would be greatly appreciated. Thanks in advance!

metalguitarist613
Offline
Joined: 08/12/2012

Hydrogen 0.9.6b1, JackOSX 0.89 (64/32 bit), and March 2011 MacBook Pro 13" if that information is relevant.

wolke
wolke's picture
Offline
Joined: 03/30/2010

hi,

in hydrogen.app/Contents/Frameworks folder you can remove the file libjack.0.dylib. normally this wiil fix your jack problem.

also if you are interested, you can try this latest development version of hydrogen. i build it today under osx 10.7.4. in this version it is possible to export tempo changes.

greetings wolke

metalguitarist613
Offline
Joined: 08/12/2012

Thank you very much. The new build exports songs with tempo changes excellently!

NecroSado
Offline
Joined: 04/23/2014

First of all, sorry for resurrecting that topic.

The problem is still alive. My needs was to sync playback between Ardour and Hydrogen so i could compose drum easily on my songs.

Just wanted to say that deleting libjack.0.dylib is working fine for me!

 

Then using JACK in Ardour (instead of Internal) and System audio -> JACK in Hydrogen makes both synced.

Really makes my day!