Skip to Content

No sound

6 replies [Last post]
Ibra
Ibra's picture
Offline
Joined: 08/18/2012

Hi there.

I am having a trouble playing file I created. I created file on Windows XP and I am now trying to play it on Windows 7 (could this be problem?).

Thanks for help.

thijs
thijs's picture
Offline
Joined: 04/20/2010

hi Ibra,

do you hear sound when you play the samples manually ? (using the mouse or by pressing the z,x,c ... keys on the keyboard)

do you have the (correct) drumkit loaded ?

grtz

Ibra
Ibra's picture
Offline
Joined: 08/18/2012

Hi thijs. I couldn't hear the sounds when I played the samples manually.

I'm sure that I had correct drumkit loaded. Now I tried to change drumkit and I got sound. Then I switched back to basic drumkit (GMkit) and I still had sound. I closed program and opened it again... no sound. So, although GMkit was already applied, I right-clicked on it and hit the first one (in english it's probably 'load' or 'input'  or something like that) and it worked. So that did the trick.

Thanks anyway.

thijs
thijs's picture
Offline
Joined: 04/20/2010

Hi Ibra

glad you can work around this issue, but it still sounds like a bug to me

would you care to create a bug report for it ?  just goto https://github.com/hydrogen-music and on the 'Issues' tab you can create a nuw ticket

btw: what version are you using ?

grtz

thijs
thijs's picture
Offline
Joined: 04/20/2010
Ibra
Ibra's picture
Offline
Joined: 08/18/2012

ok, thanks. i'm using version 0.9.6

wolke
wolke's picture
Offline
Joined: 03/30/2010

> I am having a trouble playing file I created. I created file on Windows XP and I am now trying to play it on Windows 7 (could this be problem?).

this is a known bug and already fixed in git head.

the problem is that hydrogen in this version write songfiles which containing the sample links with absolute file names. this make it impossible to share songs between different user and/or operating systems.

if you use only one drumkit in your song, simple load the corresponding drumkit via sondlibrary right click context menu. after this the samples will played. at least save the song via ctrl+s.

a workaround against this bug.