Skip to Content

libstdc++.so.6: version `GLIBCXX_3.4.15' not found

8 replies [Last post]
Johnny Thunders
Offline
Joined: 09/12/2012

Hi,

I'm trying to compile Hydrogen 0.9.6 on Slacko Puppy 3.3. But afterward, when I try to run it, I get the error:

sh-4.1# hydrogen
hydrogen: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by hydrogen)

The same thing happens when I compile the git version. I've tried installing libstdc++6_4.6.3-1ubuntu5_i386.deb but it doesn't change anything.

Any ideas?

mauser
Offline
Joined: 03/30/2010

Hi!

A similar case is described here: http://www.linuxquestions.org/questions/slackware-14/usr-lib64-libstdc-s... .

Have you tried to update your gcc?

Johnny Thunders
Offline
Joined: 09/12/2012

I'm not using 64-bit, but I installed a newer version of libstdc++.so.6 like the person did in the thread.

No, I haven't upgraded gcc. It's not as easy on Puppy Linux as you might think, and all my programs are compiled against whatever I have now, so I was hoping there was some other way.

mauser
Offline
Joined: 03/30/2010

Hi!

Either your version is not new enough or the newest version of libstdc++.so.6 cannot be found on your system. Have a look at google search for 'GLIBCXX_3.4.15', there are a lot of possibilities.

Johnny Thunders
Offline
Joined: 09/12/2012

Have a look at google search

I did that.

As for gcc, it seems to be new enough:

sh-4.1# gcc -v
Reading specs from /usr/lib/gcc/i486-slackware-linux/4.5.2/specs
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/i486-slackware-linux/4.5.2/lto-wrapper
Target: i486-slackware-linux
Configured with: ../gcc-4.5.2/configure --prefix=/usr --libdir=/usr/lib --mandir=/usr/man --infodir=/usr/info --enable-shared --enable-bootstrap --enable-languages=ada,c,c++,fortran,java,objc,lto --enable-threads=posix --enable-checking=release --with-system-zlib --with-python-dir=/lib/python2.6/site-packages --disable-libunwind-exceptions --enable-__cxa_atexit --enable-libssp --enable-lto --with-gnu-ld --verbose --with-arch=i486 --target=i486-slackware-linux --build=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 4.5.2 (GCC)

Must be something specific to the Hydrogen beta.

Anyone else out there have any ideas?

Johnny Thunders
Offline
Joined: 09/12/2012

You guys suck!

thijs
thijs's picture
Offline
Joined: 04/20/2010

well thanks Johnny!

that was very helpful

i'm sure that now you will get all the help you ever wished for !

 

grtz

Thijs

Johnny Thunders
Offline
Joined: 09/12/2012

You mean "all the help I was not going to get anyway."

You're welcome.

wolke
wolke's picture
Offline
Joined: 03/30/2010

hy johnny,

http://upload.wikimedia.org/wikipedia/commons/8/8c/Gldt.svg

an nice graphic which will show a few linux distributions on a time line. how ever, i am sure, if someone from h2 developers or forum readers have any idea what goes wrong on your system, we/they will answer. but please be considerate to the fact, that we(hydrogen devs) can not support each individual linux distribution and there compilations of software and/or software versions.

respect

wolke