Skip to Content

No MIDI output - Ubuntu 12.04 x64 + 0.9.6 beta 1 + FastTrack Pro

8 replies [Last post]
iyivanov
Offline
Joined: 03/14/2013

My problem is that in my case Hydrogen does not output any MIDI to my sound interface.

My FastTrack shows no MIDI output (there is a LED on the front that blinks whenever MIDI data goes out) and my synth is not playing anything. I have the QJack correctly configured - all the ports are connected as they should. 

If I export the song from Hydrogen and import into Rosegarden then FastTrack is blinking and the synth is singing.

Any idea?!?

chrisBu
Offline
Joined: 03/21/2013

I have the same problem,  midi out with hydrogen 9.6. I try alsa and jackmidi and monitor it with gmidimonitor. But gmidimonitor shows no midi messages form hydrogen.

I'm on Ubuntu 12.04 KXstudio, hydrogen 9.6.-beta3.

 

thanks for help

chris

 

thijs
thijs's picture
Offline
Joined: 04/20/2010

H2 does not output midi unless you configure it per instrument, unfortunately this is not yet described in the current manual

goto the intrument parameters (see http://www.hydrogen-music.org/hcms/node/5#sect.instrument_editing.parameters), and set the 'channel' and 'note' parameters for the outgoing midi for that instrument

done

 

grtz

Thijs

chrisBu
Offline
Joined: 03/21/2013

Hi,

thanks, now it works. :-)

But it's a lot of work to edit the 'channel' and 'note'  parameters for every note.

 

thanks

chris

thijs
thijs's picture
Offline
Joined: 04/20/2010

true, but it also gives you a whole lot of flexibility :-)

iyivanov
Offline
Joined: 03/14/2013

Hello Thijs,

Yeah, give each note in the drumkit a midi channel and then it start outputting the midi. The option for the midi channel is there on the screen and by default it shows OFF, but who would guess that it is meant for that purpose. I figured it out after going through the source code for about 2 hours... :o)

I am having a different problem now. My FT-P blinks when Hydrogen sends out the midi notes, but my synth does not sing still. With Roseguarden it does, as I said before. I think the synth expects a signal like which program and/or which bank eventually. At least Roseguarden does send those signals out. Or it might be that the MIDI channel is not being sent out correctly?!?

Actually, it is brilliant idea to implement the midi channel option this way. I mean, not every drumkit would be meant to be MIDI compatible, right. You got one from me on this one.

cheers,

Ivo

iyivanov
Offline
Joined: 03/14/2013

Hey ChrisBu,

No, it is not a lot of work. Just do this:

1. Close Hydrogen if it is opened.

2. Open the drumkit XML file in a text editor.

3. Do find - replace for the MidiOutputChannel node and give it a proper number. Keep in mind that 1st channel is actually number 0.

4. Restart Hydrogen and reload the sound library.

This is what I did when I figured out the midi channel feature. My sound lib has 72 sounds, so yes by hand in Hydrogen I would have gotten an RSI ;o)

cheers, Ivo

kaim
Offline
Joined: 05/13/2013

 

hi i'm trying out hydrogen as a midi sequencer on the rpi, i just installed it today.

i don't have jack running yet so the sound output is not working, but i wanted to try driving my alesis drum machine with it. 

i get midi coming in, but no midi out.  as far as i can see i have configured the midi out channels properly on the instrument panel.  they look good on the drumkit.xml file as well.

can anyone confirm if midi out is working on the wheezy build?  or is there a dependency on the jack server?  i tried midi out on seq24 and it works so the alsa driver is working...

thijs
thijs's picture
Offline
Joined: 04/20/2010

is your midi setup correct ?

since you are not using jack you should (i guess) set your midi to use alsa

see : tools - preferences - midi setup