Skip to Content

Error with ALSA

3 replies [Last post]
Mr. Asdf
Offline
Joined: 04/17/2010

I was able to install Hydrogen and everything, but when I tried it for the first time I got this error:

Hydrogen 0.9.1 [Jul 24 2005] - Copyright 2002-2004 Alessandro Cominu
Compiled modules: (Alsa) (FLAC) (OSS)

Hydrogen comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details

[WARNING] SongReader [readSong] Trying to load a song created with a different version of hydrogen.
[WARNING] SongReader [readSong] Song [/usr/share/hydrogen/data/DefaultSong.h2song] saved with version 0.9.0
[LadspaFX::getPluginList] reading directory: /usr/lib/ladspa
[LadspaFX::getPluginList] directory /usr/lib/ladspa not found
[LadspaFX::getLadspaFXGroup]
[LadspaFX::getPluginList] reading directory: /usr/lib/ladspa
[LadspaFX::getPluginList] directory /usr/lib/ladspa not found
ALSA lib seq_hw.c:455:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory
[ERROR] AlsaMidiDriver Error opening ALSA sequencer
[ERROR] AlsaAudioDriver Can't set realtime scheduling for ALSA Driver
[WARNING] Hydrogen [audioEngine_setupLadspaFX] m_pSong=NULL
[WARNING] Hydrogen [audioEngine_process] trylock != 0. Frames = 0. Lock in InstrumentPropertiesDialog::layerSelected
[ERROR] AlsaAudioDriver [alsaAudioDriver_processCaller] XRUN

I have all the latest ALSA packages installed on my CRUX linux:
# pkginfo -i | grep alsa
alsa-driver 1.0.9b-1
alsa-lib 1.0.9-1
alsa-oss 1.0.9-1
alsa-utils 1.0.9a-1

what do I need to do now?
any help will be appreciated.

marotte
Offline
Joined: 04/17/2010

I've got the same problem here :

hydrogen 0.9.4 works well with the OSS output but using the ALSA output :

[ERROR] AlsaAudioDriver Can't set realtime scheduling for ALSA Driver
[ERROR] Button Error loading pixmap: /usr/local/share/hydrogen/data/img/gray/mixerPanel/led_trigger_on.png
[ERROR] Button Error loading pixmap: /usr/local/share/hydrogen/data/img/gray/mixerPanel/led_trigger_off.png
[ERROR] Button Error loading pixmap: /usr/local/share/hydrogen/data/img/gray/mixerPanel/led_trigger_off.png

[snip]

[ERROR] Button Error loading pixmap: /usr/local/share/hydrogen/data/img/gray/mixerPanel/led_trigger_off.png
[ERROR] AlsaAudioDriver [alsaAudioDriver_processCaller] XRUN
[ERROR] AlsaAudioDriver [alsaAudioDriver_processCaller] XRUN

marotte
Offline
Joined: 04/17/2010

In fact it seems to work with OSS (no tic tic tic when just playing the song) but i've got a

[WARNING] OssDriver Can't set realtime scheduling for OSS Driver

And when i click on the pattern editor i hear the "tic tic"

I had this problem a long time ago, the reason was that hydrogen wasn't suid root. But there it is setuid root... I don't understand.

marotte
Offline
Joined: 04/17/2010

I've moved the hydrogen binary in place of doing a make install :)

Everything works fine now, except the names of instruments don't appear in the mixer...