Skip to Content

win ver requirements?

4 replies [Last post]
drattz
Offline
Joined: 04/17/2010

in win98 on launch, a dos box pops up with messages about loading preferences, a warning about not being able to find a locale, and then an illegal operation pops up with the following description:

HYDROGEN executed an invalid instruction in
module QTGUI4.DLL at 017f:007717aa.

then it closes after oking the error.
does this work on win98?

photon1240
Offline
Joined: 04/17/2010

I was able to get the 3/2/06 installer to run on Win98SE after downloading the missing dll's. Try that one if the newest version isn't working for you. Don't know about the 3/9/06 build.

Read this for more info:
(http://www.hydrogen-music.org/forum/index.php?action=show_thread&thread=...)

pianobeginner
Offline
Joined: 04/17/2010

got the following messages in MS-DOS Window:

(I) Preferences [Preferences] INIT
(I) Preferences [loadPreferences] Loading preferences file (GLOBAL
) [C:/PROGRAMME/HYDROGEN/data/hydrogen.default.conf]
(I) Preferences [loadPreferences] Loading preferences file (USER)
[c://.hydrogen/hydrogen.conf]
(W) Preferences [loadPreferences] Configuration file not found.
(W) Preferences [loadPreferences] Recreating configuration file.
(I) Preferences [savePreferences] Saving preferences file: c://.hy
drogen/hydrogen.conf
(I) [int qMain(int, char**)] Using locale: data/i18n/hydrogen.de_DE

And then the following window:

HYDROGEN executed an invalid instruction in
module QTGUI4.DLL at 017f:007717aa.

then it closes after oking the error.

I tried both the hydrogen-windows-installer-20060302.exe and hydrogen-windows-installer-20060309.exe installer, always the same...
Thanks for all hints.

Eldmannen
Offline
Joined: 04/17/2010

Windows 98 is very old operating system, and it is also a bad operating system too!
And Microsoft does not support it anymore.
You should not use Windows 98, especially not if the computer is connected to the Internet.

You should get Linux.

sarpism
Offline
Joined: 04/17/2010

>Windows 98 is very old operating system
not as old as unix

>and it is also a bad operating system too!
and it runs on intel hardware. your point?

>And Microsoft does not support it anymore.
if you consider cement overshoes "support"

>You should not use Windows 98
you should not use the word "should" in regard to others' behavior unless they've accepted you as guru or spiritual teacher

>especially not if the computer is connected to the Internet
>You should get Linux.
and use it in your hardware router, but certainly don't give up the software base of windows or mac for it.

from 20060609 installer thread
I don't know how picky Windows is about different architectures, but here are the dll's I built from the link provided by remline (which I assume are kosher to share - please repremand appropriately if not). Hydrogen seems to work fine now. Windows XP, Pentium-4, if it matters.

the answer is "very picky" - xp stuff is often incompatible with previous windows versions in such a way as to break other software installs, or windows itself

(from an entirely different product whose install broke 98SE)
msimg32.dll & msvcirt.dll, for example, come in different, incompatible versions. The xp ones call xp-only windows functions without bothering to check whether they're running under xp or not. A software product that installs these in 98SE breaks every piece of software that uses them - and windows uses them.

##########

I installed 20060209 version in clean 98SE, SP2.02. It started without crashing, but had a LONG list of problems (entire sound library system not working, dozens of ways to crash, with or without assertions & dialog boxes, midi crashes, settings not saved, screen elements disappearing, etc.) it's clearly not a "bug", it's a "software does not work" situation. it remains to be seen after uninstallation, how much collateral damage has been done.

Perhaps QT is going xp-only? (not likely - it PLAYS sounds just fine) or some library used by hydrogen?

at any rate, there seem to be some big issues with 98 - and I don't know where this request goes, but I would like to see explicit lists of dependencies for all the versions before installing.