Skip to Content

Hydrogen doesn't load any LADSPA Fx

2 replies [Last post]
hacar0
Offline
Joined: 04/17/2010

Hi all!
I've installed Hydrogen and LadspaSDK. This is my /usr/local/lib/ladspa listing:

$ls /usr/local/lib/ladspa
amp.so* cmt.so* delay.so* filter.so* noise.so* sine.so*

So that, when I start Hydrogen I cant find any Ladspa fx :(
And in the "General" tab of Preferences there isn't any ladspa reference.

This is my shell when I run H.:

$ hydrogen
Warning: no locale found: /usr/local/share/hydrogen/data/i18n/hydrogen.en_US
Warning: error loading locale: /usr/local/share/hydrogen/data/i18n/hydrogen.en_US.qm

Hydrogen 0.9.3 [Jun 12 2006] [http://www.hydrogen-music.org]
Copyright 2002-2005 Alessandro Cominu
Compiled modules: (FLAC) (Jack) (Alsa) (OSS)

Hydrogen comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details

Using data path: /usr/local/share/hydrogen/data
[WARNING] SongReader [readSong] Trying to load a song created with a different version of hydrogen.
[WARNING] SongReader [readSong] Song [/usr/local/share/hydrogen/data/DefaultSong.h2song] saved with version 0.9.2
[LadspaFX::getLadspaFXGroup]
[WARNING] JackDriver Jack server not running?
[ERROR] Hydrogen [createDriver] Error starting audio driver [audioDriver::init()]
[ERROR] AlsaAudioDriver Can't set realtime scheduling for ALSA Driver
[ERROR] AlsaAudioDriver Can't set realtime scheduling for ALSA Driver

I think is different as yours, because I saw some examples of yours consolle messages surfing on the forum :) . I don't know why my Hydrogen does not load any ladspa fx. I use Slackware linux 10.0, and *I think* to have any libs required (ladspa.h and ladspa_sdk of course).

Thanks,
.h

aikie
Offline
Joined: 04/17/2010

Have you tried setting LADSPA_PATH enviroment variable to /usr/local/lib/ladpsa?

hacar0
Offline
Joined: 04/17/2010

Thanks, now it works! ;D